Back to overview
Degraded
Unable to fetch emails from outlook
Mar 27 at 11:07am CET
Affected services
integrations
Resolved
Mar 27 at 11:33am CET
services restored
Affected services
integrations
Created
Mar 27 at 11:07am CET
We are currently experiencing an issue which blocks fetching of outlook emails. We are currently investigating this.
Affected services
integrations