Back to overview
Degraded
Degraded performance customer service solution
Jun 25 at 02:04pm CEST
Affected services
Chat
Email
Voice
Resolved
Jun 25 at 02:23pm CEST
We have identified the issue and solved it. Services are back online.
Affected services
Chat
Voice
Created
Jun 25 at 02:04pm CEST
Some of our customer service solution have degraded performance. We are investigating this now
Affected services
Chat
Voice