Back to overview
Downtime
Customer service solution down
Jun 26 at 02:59pm CEST
Affected services
Chat
Email
Voice
Resolved
Jun 26 at 03:10pm CEST
The root cause has been found and resolved. All solutions are back online
Affected services
Chat
Voice
Created
Jun 26 at 02:59pm CEST
Our customer service solution is currently down. We are investigating the issue and will update you asap.
Affected services
Chat
Voice