Back to overview
Downtime
Accounts payable not processing
Jul 17 at 12:13pm CEST
Affected services
Email
Resolved
Jul 17 at 02:11pm CEST
The issue has been resolved now. The invoices will start processing as usual.
Affected services
Created
Jul 17 at 12:13pm CEST
We have detected issue with the invoice processing. The invoices are paused until we remediate the issue.
Affected services