Back to overview
Downtime
Major outage of our services
Jul 31 at 05:16am CEST
Affected services
Chat
Email
Voice
Invoice processing
Document processing
Resolved
Jul 31 at 07:42am CEST
All services are back online. Apologies for the downtime. If you are still experiencing issues please contact our support team.
Affected services
Chat
Voice
Invoice processing
Document processing
Updated
Jul 31 at 07:08am CEST
We have found the root cause and are fixing the issue.
Affected services
Chat
Voice
Invoice processing
Document processing
Created
Jul 31 at 05:16am CEST
We are experiencing downtime with most of our services. We are investigating this right now.
Affected services
Chat
Voice
Invoice processing
Document processing