Overall systems are slow
Resolved
Jul 31 at 11:37am CEST
The issue with our third-party provider has been resolved, and system performance has returned to normal.
We will continue to monitor the situation closely to ensure stability. Thank you for your patience and understanding.
Affected services
portal
Chat
Voice
Invoice processing
Document processing
Updated
Jul 31 at 11:33am CEST
We have identified that this is an issue with one of our third-party providers. We are in contact to get solved as soon as possible
Affected services
portal
Chat
Voice
Invoice processing
Document processing
Created
Jul 31 at 11:00am CEST
We’re currently experiencing a temporary issue that may cause slower response times and delays in loading the portal.
Our team is actively working to resolve this as quickly as possible. We apologize for the inconvenience and appreciate your patience.
Affected services
portal
Chat
Voice
Invoice processing
Document processing