Back to overview
Degraded

Degraded performance invoice processing via email

Aug 04 at 06:00pm CEST
Affected services
Email
Invoice processing

Resolved
Aug 05 at 08:27am CEST

We have addressed the issues, and all services are back online. Thank you for your patience.

Created
Aug 04 at 06:00pm CEST

We are currently experiencing issues with our invoice processing system. As a result, some incoming emails are being incorrectly routed to "not processed" /"other" folders.

Our team is actively investigating the root cause and working on a resolution. We’ll share further updates as soon as more information becomes available.