Back to overview
Downtime
Freeday portal down
Aug 20 at 10:11am CEST
Affected services
portal
Resolved
Aug 20 at 10:42am CEST
All services are back online
Affected services
Created
Aug 20 at 10:11am CEST
The Freeday portal is down. We are investigating the issue and will update this page as we know more. Apologies for the inconvenience.
Affected services