Back to overview
Downtime

Outlook Emails Not Being Picked Up by Digital Employees

Dec 22 at 11:35am CET
Affected services
Invoice processing

Resolved
Dec 22 at 12:09pm CET

We found the issue and resolved it. Our digital employees are processing outlook emails again.

Created
Dec 22 at 11:35am CET

We are currently experiencing an issue where incoming emails via Outlook are not being picked up by our digital employees. As a result, tasks such as email sorting, invoice processing may be delayed.