Digital employees responding slower than usual
Resolved
Mar 18, 2026 at 05:07pm UTC
Response times for digital employees have returned to normal levels.
We have implemented adjustments and are continuing to closely monitor performance to ensure stability. While we are confident the issue is resolved, we will keep an eye on the system.
Affected services
Updated
Mar 18, 2026 at 09:19am UTC
We are seeing a recurrence of the earlier issue affecting digital employees. You may again notice slower response times across Chat, Email, Voice, Invoice processing, and Document processing.
Our team is actively investigating and working to restore normal performance as quickly as possible. We will share another update shortly.
Affected services
Updated
Mar 18, 2026 at 08:33am UTC
We are still experiencing an issue affecting digital employees.
You may notice that responses from your digital employee are taking longer than usual — in some cases up to a few minutes.
We are actively monitoring the situation and working to restore normal response times. We will provide an update as soon as we have more information.
Affected services
Created
Mar 18, 2026 at 07:00am UTC
We are currently experiencing an issue affecting digital employees.
You may notice that responses across Chat, Email, Voice and Document processing are slower than usual, with delays in some cases.
Our team is investigating the cause and working to restore normal response times as quickly as possible. We will provide another update as soon as we have more information.
Affected services