Back to overview
Degraded

Degraded performance of our Digital Employees

Mar 18, 2026 at 09:50am UTC
Affected services
Chat
Email
Voice

Resolved
Mar 18, 2026 at 10:25am UTC

The problems have been resolved and we are fully operational again.

Created
Mar 18, 2026 at 09:50am UTC

We are currently experiencing problems with our Digital Employees. The problem has been found and a solution is being deployed.