Back to overview
Degraded
Slow digital employees
Mar 21 at 09:15am CET
Affected services
skills
Resolved
Mar 21 at 11:26am CET
The issue has been resolved please notify us if you experience any slowness.
Affected services
skills
Created
Mar 21 at 09:15am CET
Due to problems in the Azure UK region we are expecting slowdowns. We will keep you updated.
Affected services
skills