Back to overview
Degraded

Degraded performance from a third party supplier

Sep 17 at 04:00pm CEST
Affected services
Invoice processing
Document processing

Resolved
Sep 18 at 10:45am CEST

The document-processing engine is fully operational again, and the backlog of documents has been successfully cleared. Processing times have returned to normal.

Created
Sep 17 at 04:00pm CEST

Due to an issue with a third-party service, one of our document-processing engines is experiencing degraded performance. As a result, document processing is slower than normal.