Back to overview
Degraded

Phone calls may take longer to connect

Sep 30 at 05:51pm CEST
Affected services
Voice

Resolved
Oct 01 at 08:00am CEST

The issue causing delays in connecting phone calls to our systems has been resolved. Calls are now connecting as expected, and the welcome message from the digital employee plays without delay.

Created
Sep 30 at 05:51pm CEST

We are experiencing delays in routing some phone calls to our systems. In certain cases, it may take up to a minute for the welcome message from the digital employee to be heard.

Our team is actively monitoring the situation and working to restore normal connection times. We will provide updates as more information becomes available.