Back to overview
Degraded
Degraded performance on some accounts payable solutions
Nov 19 at 09:59am CET
Affected services
Invoice processing
Resolved
Nov 19 at 10:36am CET
The issues has been resolved and invoices are processed as usual.
Affected services
Created
Nov 19 at 09:59am CET
We have noticed a degraded performance in our accounts payable solution. We are investigating this now.
Affected services