Back to overview
Degraded
Degraded performance on our customer service solution
Nov 24 at 03:12pm CET
Affected services
Chat
Email
Voice
Resolved
Nov 24 at 03:30pm CET
The services are now back to full capacity.
Affected services
Created
Nov 24 at 03:12pm CET
We are experiencing slow replies on our customer service solution. We are working to solve the problem.
Affected services