Back to overview
Degraded

Services degraded

Dec 5, 2025 at 8:49am UTC
Affected services
Chat
Email
Voice
Invoice processing
Document processing

Resolved
Dec 6, 2025 at 8:54am UTC

The external services have recovered and our system is fully operational again.

Updated
Dec 5, 2025 at 3:31pm UTC

We are still experiencing issues, and some services may be slow or intermittently unavailable. We’re continuing to investigate and will provide more updates as we learn more.

Updated
Dec 5, 2025 at 2:51pm UTC

The external service issues have been resolved, and our services are now operating normally. Thanks for your patience!

Created
Dec 5, 2025 at 8:49am UTC

We are currently experiencing degraded performance due to issues with our external service providers. As a result, some of our services may load more slowly than usual. We are monitoring the situation closely and will provide updates as more information becomes available. Thank you for your patience.