Back to overview
Degraded

Degraded performance

Dec 08 at 04:36pm CET
Affected services
Chat
Email
Voice

Resolved
Dec 08 at 04:50pm CET

We have deployed a fix and systems are back to normal.

Created
Dec 08 at 04:36pm CET

We are currently experiencing degraded performance due to a similar issue with our external service providers. As a result, some of our services may load more slowly than usual. We are deploying a fix as we speak and we are monitoring the situation closely and will provide updates as more information becomes available. Thank you for your patience.