Degraded performance affecting KYC, email sorting, and topics
Resolved
Mar 04 at 04:57pm CET
The issue has been resolved. Services such as KYC verification, email sorting, and topic detection should now be operating normally.
Our team will continue to monitor the platform to ensure everything remains stable.
Affected services
Updated
Mar 04 at 03:49pm CET
We have identified the cause of the issue and are currently working on a fix.
Affected services
Created
Mar 04 at 02:20pm CET
We are currently experiencing an issue with our KYC verification service. As a result, identity verification may not work at the moment.
Our team is investigating the issue and working to restore the service as quickly as possible. We will provide another update soon.
Affected services