Back to overview
Degraded

Accounts payable and KYC slower processing times

Mar 05 at 07:39am CET
Affected services
Invoice processing
Document processing

Resolved
Mar 05 at 10:43am CET

The emails and documents are being processed as usual. We will ensure we can recover from these issues in a faster manner. We apologize for the inconvenience.

Updated
Mar 05 at 10:08am CET

We have fixed the issue and see the emails and KYC slowly picking up. We will continue to monitor until the everything is fully operational.

Created
Mar 05 at 07:39am CET

We are seeing delays with processing of emails, invoices and KYC documents.
Our mechanism that determines whenever your email is an invoice or a reminder is relying on a 3rd party component (Azure cloud) which is experiencing issues.

We have located the issue and preparing a fix.