Freedah Platform Unavailable
Resolved
Mar 23, 2026 at 01:05pm UTC
All Freeday services have been restored and are now operating normally.
Chat assistants, email handling, voice services, invoice processing, and the Freeday Portal are functioning as expected. We will continue to monitor the situation closely to ensure stability.
Affected services
Created
Mar 23, 2026 at 12:45pm UTC
We are currently experiencing a platform-wide outage affecting all Freeday services.
Chat assistants, email handling, voice services, invoice processing, and the Freeday Portal are currently unavailable. Our team is actively investigating the issue and working to restore service as quickly as possible.
We will provide an update as soon as we have more information.
Affected services